Issue with Composites

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Karin1610
Posts: 80
Joined: Sun Jul 23, 2017 9:07 am

Issue with Composites

Post by Karin1610 » Thu Jan 11, 2018 1:19 pm

Hi!
I noticed a strange thing with my composites. Using "Complete Composites" worked fine at first.
But since I made them I've added lots of characters from the Private Use Area for my syllable bows, and now I found out by accident that klicking "Complete Composites" no longer uses the correct glyphs for the diacritical marks. Instead it uses those syllable bows I've made.
It doesn't happen with all characters, only the caps and the lower case i's.
If I delete all the bow characters, it works fine again.
composites.jpg
composites.jpg (109.56 KiB) Viewed 139 times

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7381
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Issue with Composites

Post by Bhikkhu Pesala » Thu Jan 11, 2018 3:13 pm

That is because a number of code points in the PUA are used by the Complete Composites feature.

Set the Glyph Overview to use Decimal code-points (Ctrl+J)

If you have used any of these code-points (at the start of the PUA) for your bows, they will be used to compose accents for Uppercase accented composites.

57365-57378 Low Profile Diacritics for Uppercase or Small/Petite Capitals

Low profile diacritics are useful in some fonts for smaller accents above capitals.

I think you can solve the problem by removing the code-points for the bows. If you have used OpenType features for them, they use glyph names, not code-points. However, if you need users of your font to insert these code-points from the PUA using a character map, then they will need code-points.

In that case, either assign different code-points in the PUA, or copy all of those glyphs, remove the code points, then complete composites on the Uppercase Latin glyphs, before pasting the code-points back with Paste Special.
My FontsReviews: MainTypeFont CreatorHelpFC11.5 Pro + MT8.0 @ Win10 1803

Karin1610
Posts: 80
Joined: Sun Jul 23, 2017 9:07 am

Re: Issue with Composites

Post by Karin1610 » Thu Jan 11, 2018 6:37 pm

Thank you! I think your last suggestion will be the most useful for me. I'll try that out.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest