Page 1 of 1

Weird thing happening with points

Posted: Thu Feb 22, 2018 8:46 am
by Karin1610
There's something strange going on when I'm moving outlines.
I imported a letter made in Corel Draw and it showed fine with no faulty points. But then I moved it to its correct place and suddenly a red point appeared and part of the previously smooth outline was cut off.
weird1.jpg
weird1.jpg (9.28 KiB) Viewed 1840 times
Just moving it to another spot fixes it again.
weird2.jpg
weird2.jpg (10.39 KiB) Viewed 1840 times
It's a matter of trial and error until I finally get it correctly to where it's supposed to be.

Re: Weird thing happening with points

Posted: Thu Feb 22, 2018 8:55 am
by Bhikkhu Pesala
Open the Validation Toolbar and fix any issues.

Try right-click, optimise.

Re: Weird thing happening with points

Posted: Thu Feb 22, 2018 9:01 am
by Erwin Denissen
If the outline is tiny (e.g. only a few units in height or width), then this can happen as fonts use rounded values.

If this is happening, then it is probably best to change Pixels per em as available on the Options dialog, on the Import tab.

Re: Weird thing happening with points

Posted: Thu Feb 22, 2018 4:06 pm
by Karin1610
Bhikkhu Pesala wrote:
Thu Feb 22, 2018 8:55 am
Open the Validation Toolbar and fix any issues.

Try right-click, optimise.
Thank you very much, optimize works more ore less. It sometimes changes the outline in a not desired way though.
Erwin Denissen wrote:
Thu Feb 22, 2018 9:01 am
If the outline is tiny (e.g. only a few units in height or width), then this can happen as fonts use rounded values.

If this is happening, then it is probably best to change Pixels per em as available on the Options dialog, on the Import tab.
The outline isn't tiny, I'd say. This is the lower case x and its height is 700.
I have seen the Pixels per em setting, but I never changed it. It's set to 512, but I don't know if this is alright. Is there any suggestion on how to determine an appropriate value?

Re: Weird thing happening with points

Posted: Thu Feb 22, 2018 4:30 pm
by Erwin Denissen
Karin1610 wrote:
Thu Feb 22, 2018 4:06 pm
The outline isn't tiny, I'd say. This is the lower case x and its height is 700.
I have seen the Pixels per em setting, but I never changed it. It's set to 512, but I don't know if this is alright. Is there any suggestion on how to determine an appropriate value?
Then that isn't the problem, but you might still see rounding issues.

In point mode, right-click and select Round XY Coordinates if you want to round coordinates values while designing your outlines.

Can you send the project file to us?

Re: Weird thing happening with points

Posted: Fri Feb 23, 2018 2:35 pm
by Karin1610
Erwin Denissen wrote:
Thu Feb 22, 2018 4:30 pm
In point mode, right-click and select Round XY Coordinates if you want to round coordinates values while designing your outlines.
I've tried this and now moving the outlines doesn't cause the described issue.
Erwin Denissen wrote:
Thu Feb 22, 2018 4:30 pm
Can you send the project file to us?
Yes, I'll send it via email. As I said, the screenshots have been taken from the lower case x.

Thanks for the help.

Re: Weird thing happening with points

Posted: Tue Mar 06, 2018 12:38 pm
by Erwin Denissen
I've made some improvements to the movement of points and contours.

Do download and install this release and let us know your results:

FontCreator 11.0.0.2423 (64 bit edition)

Re: Weird thing happening with points

Posted: Tue Mar 06, 2018 1:00 pm
by Karin1610
Thank you! I'll give it a try!

Re: Weird thing happening with points

Posted: Tue Mar 06, 2018 1:06 pm
by Erwin Denissen
The changes concern the way values are rounded, so this improvement needs some testing to ensure it doesn't break other rounding related tasks.

Re: Weird thing happening with points

Posted: Thu Mar 08, 2018 7:12 am
by Karin1610
Okay.
So far I didn't see anything happen. If I do, I'll report it.