Page 1 of 1

Black Letter B behind my Colour Letters

Posted: Wed Mar 28, 2018 12:08 pm
by Wind-2013
Re: No Contours Found in the Vector Data
I dont' have the latest version. But I found, that when I put blend mode from DARKEN to the NORMAL, it becomes everything fine. =)

But now I have another problem.
I want to create color font, but behind my color letters in the test I see black letter B. Why?
Image

Re: Black Letter B behind my Colour Letters

Posted: Wed Mar 28, 2018 12:29 pm
by Bhikkhu Pesala
If you can attach the font project file, that may be the quickest way to a solution.

Probably you have the letter B as one of the layers in other letters.

See the tutorial on Creating Multicoloured Glyphs

Re: Black Letter B behind my Colour Letters

Posted: Wed Mar 28, 2018 12:53 pm
by Wind-2013
Here is my project file

When I open window Preview in the FontCreator, everything looks as it should be.
But when I go Font -> Test WOFF I see these black blocks

Re: Black Letter B behind my Colour Letters

Posted: Wed Mar 28, 2018 3:02 pm
by Erwin Denissen
The first glyph must be .notdef which seems to be deleted. Chrome doesn't like it, so insert a glyph at the top and name it .notdef.

Re:Black Letter B behind my Colour Letters

Posted: Wed Mar 28, 2018 3:09 pm
by Bhikkhu Pesala
  1. Start a new font project
  2. Copy the first three (required) glyphs (.notdef, null, nonmarking return)
  3. Insert three blank new glyphs to your colour font
  4. Paste the three required glyphs with their mappings.
  5. Try testing your font again.
Required glyphs.png
Required glyphs.png (3.38 KiB) Viewed 846 times
Preview.png
Preview.png (10.72 KiB) Viewed 846 times

Re: Black Letter B behind my Colour Letters

Posted: Thu Mar 29, 2018 2:09 pm
by Wind-2013
It works *_*

Thank you.
You've helped me a lot ^_^