Added Number Forms to Range but does not show up in Mac but does in Windows

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
algrass
Posts: 114
Joined: Mon Dec 10, 2007 9:02 pm
Location: West Midlands, UK
Contact:

Added Number Forms to Range but does not show up in Mac but does in Windows

Post by algrass » Wed Aug 08, 2018 6:07 pm

I added Roman numerals set 2160 to 2169 but only the first four characters contain glyphs, the others are empty.

Upon recalculating the range in the Range dialogue box, saving, exporting and installing in Mac, the Roman numerals were not listed.

I then decided to Edit the range manually and ticked the Number Forms and the range was extended by another x on the dash lines, implying that the selection had been recognised and added to the range.

However, if I click the "Calculate" button the selected number form range disappears. I assume that this apparent malfunction can be due to the fact that only the first 4 glyphs are present in the series. I then proceed to reselect the Number Forms again, manually, the x reappeared and saved the file and exported it as .otf.

I can see the first 4 Roman numerals in the Windows character map, but I cannot see them in my Mac Font Book.

I suppose I could have entered some dummy glyphs in the remainder of the Roman Numerals character list I had selected, but I only thought of this while writing this message.

Does anyone know the reason why my Mac does not show these four Roman numeral glyphs?

Erwin Denissen
Moderator
Moderator
Posts: 7398
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Added Number Forms to Range but does not show up in Mac but does in Windows

Post by Erwin Denissen » Fri Aug 17, 2018 7:29 pm

To be sure, you used Insert Characters to add this range:
$2160-$2169

Then you used Complete Composites to generate the outlines?

If so, then you should see all outlines unless your font misses some of the "base" glyphs (e.g. Latin Capital Letter I, V, and X).

If these are the only Number Forms, then you need to manually set this Unicode range, and uncheck the "Automatically update character ranges when exporting font".

If your Mac still fails to show then, then it must be lack of support on the Mac side.
Erwin Denissen
High-Logic
Proven Font Technology

algrass
Posts: 114
Joined: Mon Dec 10, 2007 9:02 pm
Location: West Midlands, UK
Contact:

Re: Added Number Forms to Range but does not show up in Mac but does in Windows

Post by algrass » Sun Aug 26, 2018 9:05 pm

Erwin Denissen wrote:
Fri Aug 17, 2018 7:29 pm
To be sure, you used Insert Characters to add this range:
$2160-$2169
Correct Erwin
Then you used Complete Composites to generate the outlines?
No, I created new glyphs, only the first four as those were what I needed and left the other empty.

I was able to resolve this problem by unchecking the "Automatically etc etc default tick.

However, tonight I added two Cyrillic glyphs, small s circumflex and small s caron. I recalculated the range with or without the tick in the "Automatic etc" but my Mac cannot see them but Windows can.

There is something strange going on.

How do I go about setting the range manually to ensure that the Cyrillic range is selected? Or could it be that there are not enough Cyrillic glyphs chosen and the program, therefore, ignores the two characters I inserted? But this cannot be else both Mac and Windows would show the same result. Intriguing!

Erwin Denissen
Moderator
Moderator
Posts: 7398
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Added Number Forms to Range but does not show up in Mac but does in Windows

Post by Erwin Denissen » Mon Aug 27, 2018 10:23 am

You could look into fonts that do work as expected to see what settings they use.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply