8 characters not showing - only in FontCreator are shown

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
ovicrosstitch
Posts: 3
Joined: Thu Jul 18, 2019 2:58 pm

8 characters not showing - only in FontCreator are shown

Post by ovicrosstitch » Thu Jul 18, 2019 4:43 pm

Hi!
I am so happy I found this wonderful software called High-Logic FontCreator.
Thank you so much to the creator!

I have a font that came with my cross stitch software.
The font is used to assign symbols to the threads used when converting a picture into a cross stitch design.
In the cross stitch software, I can see only 214 characters.

Opening that font in FontCreator, I was shocked to see there are 226 characters/glyps.
I even select the ones I can not see in my cross stitch software.
Image

So, 226 - 214 = 12 characters I do not see at all.
I can see a .notdef, .null, nonmarkingreturn, space. Let's ignore these 4.
What about the other 8 that FontCreator sees but my software doesn't?
Image
What can I do to those 8 characters so they can be usable?

Thank you!

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8357
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: 8 characters not showing - only in FontCreator are shown

Post by Bhikkhu Pesala » Thu Jul 18, 2019 5:01 pm

The glyph overview side panel shows 8 glyphs that are "Undefined."

Check their properties using the Glyph Properties toolbar (F4).
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

ovicrosstitch
Posts: 3
Joined: Thu Jul 18, 2019 2:58 pm

Re: 8 characters not showing - only in FontCreator are shown

Post by ovicrosstitch » Thu Jul 18, 2019 5:21 pm

Yes, I see that, I accessed the "Undefined" section, I clicked on a glyph, pressed F4, then clicked the red button "Select Unicode character", I chose one and after clicking Apply, the glyph disappeared. I did that to all 8, choosing different Unicode character.
I saved, exported as ttf, copied in the windows Fonts folder, open my cross stitch program and they do not show there...
What should I do?

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8357
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: 8 characters not showing - only in FontCreator are shown

Post by Bhikkhu Pesala » Thu Jul 18, 2019 5:35 pm

From the User Manual
Note: only the first 224 characters of symbol fonts will be accessible: a space and up to 223 printing characters.
Convert the font to a Unicode font (from the Tools menu) to access more characters.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

ovicrosstitch
Posts: 3
Joined: Thu Jul 18, 2019 2:58 pm

Re: 8 characters not showing - only in FontCreator are shown

Post by ovicrosstitch » Thu Jul 18, 2019 5:45 pm

Thank you, I did not know that. Valuable information.
The convert to Unicode is not available. What am I doing wrong?
Image

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8357
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: 8 characters not showing - only in FontCreator are shown

Post by Bhikkhu Pesala » Thu Jul 18, 2019 5:59 pm

Then it is already a Unicode font.

Either you have not successfully replaced the old version with the new one, or your Cross Stitch software expects to find a symbol font.

Which Unicode code-points did you assign to the 8 undefined glyphs?
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

Post Reply