[FIXED] Some GSUB substitutions not displaying in Preview window

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Post Reply
graphity
Posts: 9
Joined: Sat Jul 22, 2017 6:44 am

[FIXED] Some GSUB substitutions not displaying in Preview window

Post by graphity » Fri Mar 16, 2018 10:02 am

Hi, I'm honestly not sure if this is a bug or not because I'm aware that the Font Creator Preview window does not necessarily give a full 100% representation of absolutely all features. I'm working with a Devanagari designed for the Universal Shaping Engine's Indic implementation. One of the lookups in one of my features is just not displaying in the Preview window as it is supposed to - the programmed GSUB substitutions are not occurring. These same substitutions work just fine in applications eg Word. They also work fine in FontLab and in DTL OT Master. But for some reason not in Font Creator. The feature is a fairly basic one - Below Base Substitutions (blws). The substitutions are quite "legal" and the feature syntax checks out 100% in Font Creator. Any ideas? Regards, Kevin.

Erwin Denissen
Moderator
Moderator
Posts: 7294
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Some GSUB substitutions not displaying in Preview window

Post by Erwin Denissen » Fri Mar 16, 2018 1:10 pm

Maybe the feature is not connected with the correct script. Can you send us the project file along with a sample text to test?
Erwin Denissen
High-Logic
Proven Font Technology

graphity
Posts: 9
Joined: Sat Jul 22, 2017 6:44 am

Re: Some GSUB substitutions not displaying in Preview window

Post by graphity » Sat Mar 17, 2018 12:35 am

Thanks for your offer of assistance. As the project is commercial in nature and still in development I need to request a means of sending the file privately. Please let me know how I can send an attachment privately to you. Regards, Kevin.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7378
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Some GSUB substitutions not displaying in Preview window

Post by Bhikkhu Pesala » Sat Mar 17, 2018 5:56 am

My FontsReviews: MainTypeFont CreatorHelpFC11.5 Pro + MT8.0 @ Win10 1803

graphity
Posts: 9
Joined: Sat Jul 22, 2017 6:44 am

Re: Some GSUB substitutions not displaying in Preview window

Post by graphity » Sat Mar 17, 2018 7:37 am

Done! Thanks. regards, Kevin,

Erwin Denissen
Moderator
Moderator
Posts: 7294
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Some GSUB substitutions not displaying in Preview window

Post by Erwin Denissen » Sat Mar 17, 2018 12:49 pm

I'm not sure but I suspect FontCreator was a bit too strict as it didn't allow ligature combinations with Simple and Mark glyphs. We'll remove that check with the next upcoming release.
Erwin Denissen
High-Logic
Proven Font Technology

graphity
Posts: 9
Joined: Sat Jul 22, 2017 6:44 am

Re: Some GSUB substitutions not displaying in Preview window

Post by graphity » Sun Mar 18, 2018 12:47 am

Such a restriction ie blocking Simple to Mark ligatures would certainly explain why this strange issue is occurring. Using Lookup Type 4 for Simple to Mark and Mark to Mark ligatures is definitely part of the standard methodology for Devanagari script - see Microsoft's doc "Developing OpenType Fonts for Devanagari Scripts". Looking forward to the fix. Many Thanks. Regards, Kevin.

Erwin Denissen
Moderator
Moderator
Posts: 7294
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Some GSUB substitutions not displaying in Preview window

Post by Erwin Denissen » Mon Apr 16, 2018 1:49 pm

This issues has been fixed.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest