Page 1 of 1

Symbol fonts not detected by other software as symbol fonts

Posted: Wed Jun 26, 2019 5:25 am
by mc_deltat
I am trying to edit a TrueType symbol font to add some names to the glyphs. However, when exporting the font, it doesn't seem to be properly recognised by other software (specifically Windows' font APIs) as a symbol font.

I have tried using Tools->Convert Font->Convert to Symbol Font, with glyphs mapped to character codes in the range 0xF000 to 0xF0FF. Specifically, codes 0xF021 to 0xF054, which I believe should be fine as this is the range the font started with. I have also tried the range 0x21 to 0x54 just in case, which didn't work.

The FontCreator version is 12.0.0.2539, 64-bit.

Some additional info:
  • Every time I close and reopen the FontCreator project, it seems to get reverted to a Unicode font, which is strange.
  • I believe this font has been successfully edited with a previous version of FontCreator (not by me though).
  • I'm using Windows 10 Pro, version 1809, 64-bit.

Re: Symbol fonts not detected by other software as symbol fonts

Posted: Thu Jun 27, 2019 10:25 am
by Erwin Denissen
I can confirm the issue. We'll have to look into this to fix it.

Re: Symbol fonts not detected by other software as symbol fonts

Posted: Mon Jul 01, 2019 2:17 pm
by Erwin Denissen
We've located the exact cause of the issue, so the bug will be fixed with the next upcoming update.

Re: Symbol fonts not detected by other software as symbol fonts

Posted: Tue Jul 02, 2019 12:58 am
by mc_deltat
Thanks for your response. Do you know if the update will be released soon, or if there is a workaround in the meantime?

Re: Symbol fonts not detected by other software as symbol fonts

Posted: Wed Jul 10, 2019 4:07 pm
by Erwin Denissen
We've just uploaded a maintenance release that solves this issue. Do use the update feature within FontCreator get this latest version, or download it from the download page.