[FIXED] Mark positioning values

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Post Reply
dhiman4us@gmail.com
Posts: 42
Joined: Sat May 30, 2020 7:24 pm

[FIXED] Mark positioning values

Post by dhiman4us@gmail.com » Sat Jun 20, 2020 9:42 am

Mark positioning values are not being exported correctly in Indic Fonts..here I have attached images from Adobe Devanagari..I just opened the original font and exported in otf/ttf without any editing..look at the difference between values before and after export...This bug persists from the very beginning of FontCreator 12 partially fixed in later versions however not completely fixed till now...I don't know how many such positioning related bugs present are unnoticed... please fix these bugs they are very irritating...

dhiman4us@gmail.com
Posts: 42
Joined: Sat May 30, 2020 7:24 pm

Re: Mark positioning values

Post by dhiman4us@gmail.com » Sat Jun 20, 2020 9:43 am

Check the imges carefully
Attachments
Adobe Devanagari 2.jpg
Adobe Devanagari 2.jpg (298.66 KiB) Viewed 629 times
Adobe Devanagari 1.jpg
Adobe Devanagari 1.jpg (288.06 KiB) Viewed 629 times

Erwin Denissen
Moderator
Moderator
Posts: 9138
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Mark positioning values

Post by Erwin Denissen » Sat Jun 20, 2020 10:10 am

It indeed seems to be a FontCreator bug. Thank you for reporting it. If we are not aware of bugs, we obviously won't be able to fix 'm.

Under normal circumstances you won't notice the bug, but this particular font has issues, as it stats the left side bearing is at x = 0, while some glyphs have it offset by one.

We will look into this further and hope to find a fix soon.
Erwin Denissen
High-Logic
Proven Font Technology

dhiman4us@gmail.com
Posts: 42
Joined: Sat May 30, 2020 7:24 pm

Re: Mark positioning values

Post by dhiman4us@gmail.com » Sat Jun 20, 2020 10:21 am

Sir I have another request regarding the test windows..Can you check your mail please? For privacy I cannot share the issue here..

Erwin Denissen
Moderator
Moderator
Posts: 9138
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Mark positioning values

Post by Erwin Denissen » Sat Jun 20, 2020 10:34 am

I have received your email, which is about the fact FontCreator does not work with all scripts.

See the user manual about that:
https://www.high-logic.com/fontcreator/ ... ofing.html

Note: the preview within FontCreator relies on the internal Shaping Engine which currently supports many but not all scripts. If you are in need of improvements, do let us know!

So I strongly suggest to post a request in the appropriate forum section.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 9138
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Mark positioning values

Post by Erwin Denissen » Sat Jun 20, 2020 11:36 am

We have just released an update that solves the anchor issue.
Erwin Denissen
High-Logic
Proven Font Technology

dhiman4us@gmail.com
Posts: 42
Joined: Sat May 30, 2020 7:24 pm

Re: Mark positioning values

Post by dhiman4us@gmail.com » Sat Jun 20, 2020 7:25 pm

Thank you for quick response

Post Reply