Dminx!

Discuss FontCreator here, please do not post support requests, feature requests, or bug reports!
Post Reply
Psymon
Posts: 289
Joined: Wed Mar 30, 2011 5:50 pm

Dminx!

Post by Psymon » Mon Nov 20, 2017 10:46 pm

Uh-oh, what'd I do wrong? :shock:

So I'm pluggin' away here at two new fonts, a new historical roman and italic font to go along with my historical blackletter font, and don't ask me how, but I suddenly realized that somewhere along the way I deleted the semicolon from the former two fonts. Don't ask me how that happened! But that was easy enough to replace them (since all three fonts use the same punctuation, etc.) -- or so I thought.

All I did to fix that was go under Insert -> Characters, and then selected the semicolon and added it in (and then copied the glyphs from my blackletter font to the roman/italic fonts).

And then I went to re-install those roman/italic fonts, but at the end of the process, instead of getting the usual "Enjoy!" message," instead I got "Dminx!"

What went wrong? :roll:

Erwin Denissen
Moderator
Moderator
Posts: 7394
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Dminx!

Post by Erwin Denissen » Mon Nov 20, 2017 10:51 pm

FontCreator 11?

CFF (PostScript) font?
Erwin Denissen
High-Logic
Proven Font Technology

Psymon
Posts: 289
Joined: Wed Mar 30, 2011 5:50 pm

Re: Dminx!

Post by Psymon » Mon Nov 20, 2017 10:59 pm

Erwin Denissen wrote:
Mon Nov 20, 2017 10:51 pm
FontCreator 11?
Yup!
CFF (PostScript) font?
I have no idea -- this is how dumb (uneducated) I am about what I'm doing. :mrgreen:

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7499
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Dminx!

Post by Bhikkhu Pesala » Mon Nov 20, 2017 11:00 pm

Check in File Export Options.
My FontsReviews: MainTypeFont CreatorHelpFC11.5 Pro + MT8.0 @ Win10 1803 build 17134.345

Psymon
Posts: 289
Joined: Wed Mar 30, 2011 5:50 pm

Re: Dminx!

Post by Psymon » Mon Nov 20, 2017 11:06 pm

Bhikkhu Pesala wrote:
Mon Nov 20, 2017 11:00 pm
Check in File Export Options.
Do you mean for whether my font is a "CFF (PostScript) font"? Oh, if you mean under the "Outline format" option in there, it's set as "TrueType," not "CFF (Postscript)." I didn't export the fonts, though, I only (re-)installed them directly from FC.

EDIT: Oh, I just noticed that when I do a WOFF test with my roman/italic fonts, everything seems to come out okay -- I had just assumed that everything was going to be bumped one character over (as with "Enjoy" coming out as "Dminx"), but all seems to be fine when I use my fonts elsewhere.

Strange... I'm not sure if there's something still wrong with my fonts, hidden in there somewhere (and bite me in the butt somewhere down the road), that I should be concerned about???

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7499
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Dminx!

Post by Bhikkhu Pesala » Tue Nov 21, 2017 6:35 am

Psymon wrote:
Mon Nov 20, 2017 11:06 pm
I had just assumed that everything was going to be bumped one character over (as with "Enjoy" coming out as "Dminx"), but all seems to be fine when I use my fonts elsewhere.
I would never have spotted that. No wonder Google could not translate Dminx. :lol:
My FontsReviews: MainTypeFont CreatorHelpFC11.5 Pro + MT8.0 @ Win10 1803 build 17134.345

Psymon
Posts: 289
Joined: Wed Mar 30, 2011 5:50 pm

Re: Dminx!

Post by Psymon » Tue Nov 21, 2017 6:47 am

LOL. ;) I'm sure you would have noticed -- it's pretty obvious, actually, because when you install a font from within FC, you do only naturally wait for the confirmation message at the end that it succeeded (which in this case is "Enjoy"!).

Still very strange, though -- I mean, I have yet to start my day's (night's, actually) work on my fonts again, but as I left it last night they seemed to be working okay in my other applications, so it's rather odd to me that that "Enjoy!" came out as "Dminx!" in FC itself. The only thing that I could attribute that to myself was that my inserting that semicolon character had somehow bumped everything over by one slot...

Hang on, let me see if it happens again, if I re-install my fonts again...

Oh, nope, not this time. I haven't really changed anything in either of those fonts since yesterday, but this time I get the normal, usual "Enjoy!" at the end.

I don't know, it's beyond me what happened there, but I guess what matters is that my fonts seem okay -- I hope. :roll:

Erwin Denissen
Moderator
Moderator
Posts: 7394
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Dminx!

Post by Erwin Denissen » Tue Nov 21, 2017 7:54 am

I'm glad it is now solved. Maybe it was due to Windows caching, but to be sure send the font file to me next time such strange thing happens.
Erwin Denissen
High-Logic
Proven Font Technology

Psymon
Posts: 289
Joined: Wed Mar 30, 2011 5:50 pm

Re: Dminx!

Post by Psymon » Tue Nov 21, 2017 10:20 am

Erwin Denissen wrote:
Tue Nov 21, 2017 7:54 am
I'm glad it is now solved. Maybe it was due to Windows caching, but to be sure send the font file to me next time such strange thing happens.
Sure, no sweat -- although I don't know if that would help you at all. I've been saving my font projects under new names every time I do anything major, and so I just went back to the version that I had before I re-inserted the slot for the semicolon, then did that (added in that slot, and the glyph for it, again), went to re-install the font to see if the same issue arose... and it didn't.

So I can't even seem to duplicate the issue by repeating the steps that I did before (which caused the issue to happen twice, when I installed both the regular and italic fonts) -- so if the problem "is now solved," I don't know how I did it. :lol:

But at least the issue has "gone away," whatever it was. I'm thinking -- maybe even hoping a little? -- that perhaps this font set of mine is magical somehow. ;)

Erwin Denissen
Moderator
Moderator
Posts: 7394
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Dminx!

Post by Erwin Denissen » Tue Nov 21, 2017 10:24 am

Earlier releases of FontCreator 11 did have this bug, but the latest version should no longer generate such faulty fonts.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply