"Invisible" sibling font

Discuss FontCreator here, please do not post support requests, feature requests, or bug reports!
Post Reply
Gregor77
Posts: 6
Joined: Wed Oct 31, 2012 1:41 pm

"Invisible" sibling font

Post by Gregor77 » Sat Sep 21, 2019 12:01 pm

Hi all

For a special app, I need to have one font for display in a textbox.
The app then processes the glyphs in order to get the vectors of the single glyphs.
No problem so far.

In reality, I don't want to process the font which is used for display, but another font.
This other font shall be not visible for users, at least not in the font selection gadget.

I found in Windows there are some fonts which begin with an @.
This @ makes that a font selection gadget doesn't list this special font.

So I thought my 'replacement' font could use the same @ as the first character of the font name.
When I try using Font Creator, I don't know which name I have to change.
I think I am through all possibilities, but in the end I never get a TT font that has such a name.

(I know @ is for vertical fonts, but as a hack to make it invisible this would be ok.)

Ideas?

PJMiller
Top Typographer
Top Typographer
Posts: 770
Joined: Tue Jun 16, 2015 8:12 pm
Location: Sheffield, South Yorkshire
Contact:

Re: "Invisible" sibling font

Post by PJMiller » Sun Sep 22, 2019 9:30 am

The '@' appears in the font selection box of some applications but it is not in the font name. Windows adds the @ sign before fonts which have been hidden by the computre user.

As far as I know you can't use that character in a valid font name. Also many applications ignore the 'Hidden' status of the font and display it anyway, albeit with a '@' sign as the first character.

You could try to find a way for the program to set the 'Hidden' flag in Windows for that font which would cause the font to disappear from many font selection dialogs for many applications.

Gregor77
Posts: 6
Joined: Wed Oct 31, 2012 1:41 pm

Re: "Invisible" sibling font

Post by Gregor77 » Sun Sep 22, 2019 6:20 pm

The '@' appears in the font selection box of some applications but it is not in the font name. Windows adds the @ sign before fonts which have been hidden by the computre user.
Aha, thanks for the clarification.
I thought it is a setting somewhere in the font file itself.

Ok, then I know what to do in here:
Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Font Management\Inactive Fonts

Solved.

Gregor77
Posts: 6
Joined: Wed Oct 31, 2012 1:41 pm

Re: "Invisible" sibling font

Post by Gregor77 » Mon Sep 23, 2019 10:32 am

No, that wasn't it.

Hiding a font here:
Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Font Management\Inactive Fonts

...does not make the @ as a leading character when the fonts get enumerated.
Means my 'problem' is NOT solved yet.

If someone knows more regarding the @, please don't hesitate to tell me.

Post Reply