Asian fonts showed up, make them go away

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
crewmember
Posts: 40
Joined: Sat Feb 13, 2010 3:26 pm

Asian fonts showed up, make them go away

Post by crewmember » Mon Feb 15, 2010 8:06 pm

I recently switched to a very functional, no problems XP system with MainType to a problem ridden Vista OS. All of a sudden about a hundred Asian fonts have shown up in my fonts on InDesign, Pagemaker, Illustrator and I assume Photoshop. They look like this on Pagemaker: @Adobe Fangson Std. R, or @ Batang. I DID NOT install any of these, can't seem to find them to make them go away. Anyone had this similar problem? thanks

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8407
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Asian fonts showed up, make them go away

Post by Bhikkhu Pesala » Tue Feb 16, 2010 6:21 am

Asian Language support can be enabled or disabled in Windows Control Panel, Regional and Language Options, Languages whether you're using XP or Vista. Enabling it will install the Asian fonts, which have names preceded by @.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

crewmember
Posts: 40
Joined: Sat Feb 13, 2010 3:26 pm

Re: Asian fonts showed up, make them go away

Post by crewmember » Tue Feb 16, 2010 1:43 pm

OK, found Language Support in Windows Control panel. everywhere it shows that US English is the selected format, I don't see anywhere to turn off Asian Language. BTW, in MainType the "@" shows up as Asian characters. Is there a place in Adobe to turn off? Although, this appeared in several adobe programs at same time. Thanks.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8407
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Asian fonts showed up, make them go away

Post by Bhikkhu Pesala » Wed Feb 17, 2010 6:13 am

crewmember wrote:OK, found Language Support in Windows Control panel. everywhere it shows that US English is the selected format, I don't see anywhere to turn off Asian Language.
You didn't look in the right place.
Asian Language Support.png
Asian Language Support.png (25.19 KiB) Viewed 5298 times
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

crewmember
Posts: 40
Joined: Sat Feb 13, 2010 3:26 pm

Re: Asian fonts showed up, make them go away

Post by crewmember » Wed Feb 17, 2010 1:52 pm

My screen does not have those options or look like what you are showing. See the capture I downloaded. If "Formats" is selected it shows "English" as choice. If I select tab "Keyboards and Languages" and select "How can I install different language packages?" my screen does not match instructions that come up for that either. Instructions read:

To install a Language Interface Pack (LIP), double-click the file to open the setup program. To install a Multilingual User Interface Pack (MUI), follow these steps:

Click to open Regional and Language Options.

Click the Keyboards and Languages tab.

Under Display Language, click Install/uninstall languages, and then follow the steps. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Note
The Display language section will only be visible if you have already installed a LIP or if your edition of Windows supports MUI. MUI packs are only available in Windows Vista Ultimate and Windows Vista Enterprise.

After you install a display language, you need to set your computer to use that language. For more information, see Change the display language.


I am using Vista Home Premium as OS
Attachments
language options.jpg
This is the screen capture that should match what you show in yours.
language options.jpg (94.18 KiB) Viewed 5288 times

Erwin Denissen
Moderator
Moderator
Posts: 8319
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Asian fonts showed up, make them go away

Post by Erwin Denissen » Wed Feb 17, 2010 2:57 pm

I'm not sure if it helps, but do try the latest (unofficial) release from here:
http://www.high-logic.com/maintype/MainType2.2.0.52.exe

To use it, download it and place it into the folder were you installed
MainType.

What's new in this unofficial release:
- Several minor improvements
- Better handling of font substitutes
- New context menu item: Open Containing Folder
- New filter option, Font Type: Unknown
- Added Foundry and a Full Font Name (Postscript) columns to the Fonts pane
- Show all Glyphs option

Note: This version is slower due to the foundry detection.

Let us know your results.
Erwin Denissen
High-Logic
Proven Font Technology

crewmember
Posts: 40
Joined: Sat Feb 13, 2010 3:26 pm

Re: Asian fonts showed up, make them go away

Post by crewmember » Wed Feb 17, 2010 4:32 pm

That is the version that I am using, 2.2 build 52. And as a side issue, it is really slow and a pain in the butt to wait and wait on it to finally show all the fonts and quit scrolling so that you can work with the program. That would be my main complaint actually about MainType is that long wait for it to stop scrolling so I can work.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8407
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Asian fonts showed up, make them go away

Post by Bhikkhu Pesala » Wed Feb 17, 2010 5:38 pm

One of the best reasons for using a font manager like MainType is so that you don't have to keep all of your fonts installed. You can organise them into groups, and just Load a group for a specific project whenever they are needed. They will be unloaded the next time you reboot.

Installing thousands of fonts is not a problem on recent versions of Windows, but does cause a problem when selecting fonts in applications. If you only keep the fonts installed that you use frequently, you will find that MainType will start much faster.

I have 281 active fonts, and MainType takes less than 15 seconds to start up and be ready for use. A warm start (restarting after using MainType earlier) is, of course, much faster — about 8 seconds. My 3 year old PC is an AMD 64 3500 Ghz with 1 Gbyte of RAM running Windows XP Home.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

Post Reply