Why don't applications display the font name?

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
GO
Posts: 1
Joined: Sat Nov 04, 2006 3:22 pm

Why don't applications display the font name?

Post by GO » Sat Nov 04, 2006 4:41 pm

When creating my own fonts and installing them. The applications don't display the font name in the font listbox only a blank space. After selecting the font within the application it's name displays properly. It happens in all the applications I use. In the fonts folder the fonts name displays properly.
If I was a psychologist I'd try to analyze other people by their signature ;)

Piper
Posts: 4
Joined: Fri Nov 24, 2006 6:48 pm

Post by Piper » Fri Nov 24, 2006 6:51 pm

I'm having this same problem. Was this question ever answered?

Erwin Denissen
Moderator
Moderator
Posts: 8269
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Fri Nov 24, 2006 7:48 pm

For symbol fonts Word displays these characters: AbCdEfGhIj

The recommended solution is to add outlines for those characters. If you created a new symbol font, then this symbol to character table might help. Resize the font overview window so it shows a grid with 16 columns. Ensure the green cells contain outlines.
Image

As a last resort you can also decide to disable showing fonts in their own font, as described here:
- Choose "Tools -> Customize"
- On the "Customize" dialog select the "Options" tab
- Uncheck "List font names in their font"
- Click the "Close" button

Do let us know your results.
Erwin Denissen
High-Logic
Proven Font Technology

Piper
Posts: 4
Joined: Fri Nov 24, 2006 6:48 pm

Post by Piper » Fri Nov 24, 2006 8:06 pm

I didn't set mine up as a symbol font, because even though my characters are runes, they represent actual letters. All of those letters in both upper and lower case have runes.

It's not showing the font in its own font, it's showing no name from the font pulldown list. Once I select the blank name, the correct font title appears on the toolbar.

If it were using the new font characters, I'd see the runes on the font pull down list, but I'm not even getting that.

The correct file is in the font directory, and everything else is fine. I just don't see the name on the font pulldown.

Erwin Denissen
Moderator
Moderator
Posts: 8269
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Fri Nov 24, 2006 9:25 pm

Are you sure you have outlines added to the characters that are used to display the font name? If so, please send the font file to me and I'll look into this issue.

One more thing, when you are modifying an installed font, don't be surprised to see strange things happen, as Windows can't handle that. To overcome this, just reboot your system and next time first uninstall a font before you save a modified version of it.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 8269
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Fri Nov 24, 2006 11:47 pm

Thanks for the font file.

I've just loaded your font and it shows up in Word just the way it should be:
Image

Have you tried it after a reboot?
Erwin Denissen
High-Logic
Proven Font Technology

Piper
Posts: 4
Joined: Fri Nov 24, 2006 6:48 pm

Post by Piper » Sat Nov 25, 2006 1:05 am

Thanks, Erwin. It doesn't appear in my drop downs of any Office packages, but once selected, the name appears in the current font selected with no problem.

I've rebooted several times - it doesn't make a difference.

If it seems to be working normally for you, I'll assume there's some sort of issue on my computer. The font is otherwise fine. I just wanted to ensure my publisher wouldn't have trouble with it.

Many thanks!

Julie

Piper
Posts: 4
Joined: Fri Nov 24, 2006 6:48 pm

Post by Piper » Sat Nov 25, 2006 1:45 pm

I received your renamed file back, Erwin. It installed properly. But if I attempt to rename it, either using Format -> Naming, or Tools -> Autonaming, the problem returns.

I'm not using any unusual characters, just trying to change the name from Ogham2 to Ogham.

Thanks for your help,
Julie

Erwin Denissen
Moderator
Moderator
Posts: 8269
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Sat Nov 25, 2006 1:54 pm

This is proof the font file is not the issue here. Most likely your Windows fonts cache is corrupt.

Delete the font cache file: C:\WINDOWS\system32\FNTCACHE.DAT (or on Windows 95/98/Me C:\Windows\ttfCache) and reboot to let Windows regenerate it.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 8269
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Thu Jan 04, 2007 8:16 am

A post from MFM most likely solves the problem. You need to look for a temporary file Microsoft Office creates to cache the previews, “fbc*.tmp”. It is located in C:\Documents and Settings\<username>\Application Data\Microsoft\Office\. You need to deleted this file and then restarted Word. That should make Word display the font name previews correctly.
Erwin Denissen
High-Logic
Proven Font Technology

AndyL
Posts: 19
Joined: Thu Jan 19, 2006 1:15 pm
Location: London, UK

Post by AndyL » Thu Apr 17, 2008 3:53 pm

Likewise; had exactly the same problem, but deleting my “fbc*.tmp” file resolved the issue.

Thanks

Andy

Post Reply